aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-11-08 15:17:08 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-11 12:19:13 +0000
commit1060955c4aa2ef66cdb4f0549f9bd8c1c332673c (patch)
tree8f5003c80475d1070c9e3117b685bccb9e05074c
parent2f2033836a5ce4064d9e4f263788a563001bc008 (diff)
downloadbitbake-1060955c4aa2ef66cdb4f0549f9bd8c1c332673c.tar.gz
bitbake-layers: show-recipes: fix help to mention -i supports multiple classes
The -i option supports more than one class, but the help didn't mention that. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bblayers/query.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bblayers/query.py b/lib/bblayers/query.py
index efd22cb45..9294dfa88 100644
--- a/lib/bblayers/query.py
+++ b/lib/bblayers/query.py
@@ -490,7 +490,7 @@ NOTE: .bbappend files can impact the dependencies.
parser_show_recipes = self.add_command(sp, 'show-recipes', self.do_show_recipes)
parser_show_recipes.add_argument('-f', '--filenames', help='instead of the default formatting, list filenames of higher priority recipes with the ones they overlay indented underneath', action='store_true')
parser_show_recipes.add_argument('-m', '--multiple', help='only list where multiple recipes (in the same layer or different layers) exist for the same recipe name', action='store_true')
- parser_show_recipes.add_argument('-i', '--inherits', help='only list recipes that inherit the named class', metavar='CLASS', default='')
+ parser_show_recipes.add_argument('-i', '--inherits', help='only list recipes that inherit the named class(es) - separate multiple classes using , (without spaces)', metavar='CLASS', default='')
parser_show_recipes.add_argument('pnspec', nargs='*', help='optional recipe name specification (wildcards allowed, enclose in quotes to avoid shell expansion)')
parser_show_appends = self.add_command(sp, 'show-appends', self.do_show_appends)