aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-10-17 11:08:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-29 11:12:07 +0000
commit0fb4b5153237af4a13b2c65711ab798b0de06c2f (patch)
tree98c64ee7715a4fae19e153da222a2481dcde788d
parent35784582fdbb2092eddec094deb6ab9c87666b5e (diff)
downloadbitbake-0fb4b5153237af4a13b2c65711ab798b0de06c2f.tar.gz
runqueue.py: not show warning for deferred multiconfig task
When follow the instructions of multiconfig from Yocto dev manual that set in core-image-sato recipe: do_image[mcdepends] = "multiconfig:x86:arm:core-image-minimal:do_rootfs" it show too many annoying warnings look like: | WARNING: Deferring mc:x86:virtual:native:/buildarea6/kkang/poky/meta/recipes-support/libxslt/libxslt_1.1.33.bb:do_populate_sysroot | after mc:arm: virtual:native:/buildarea6/kkang/poky/meta/recipes-support/libxslt/libxslt_1.1.33.bb:do_populate_sysroot Treat them as infomations rather than warnings. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/runqueue.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/runqueue.py b/lib/bb/runqueue.py
index 485d9341f..bd7f03f98 100644
--- a/lib/bb/runqueue.py
+++ b/lib/bb/runqueue.py
@@ -2767,7 +2767,7 @@ def update_scenequeue_data(tids, sqdata, rqdata, rq, cooker, stampcache, sqrq, s
sqdata.hashes[h] = tid
else:
sqrq.sq_deferred[tid] = sqdata.hashes[h]
- bb.warn("Deferring %s after %s" % (tid, sqdata.hashes[h]))
+ bb.note("Deferring %s after %s" % (tid, sqdata.hashes[h]))
class TaskFailure(Exception):