summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-07 17:47:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-20 17:23:59 +0000
commitfc7ebf3835a206a5daafd4e1b73bac2549714ad3 (patch)
tree1833e0ce927cfc6b25058ba00195b67f0c7424b3
parent0da22ba3e930fbb060b31fc423fd3333ca8843a0 (diff)
downloadbitbake-fc7ebf3835a206a5daafd4e1b73bac2549714ad3.tar.gz
siggen: Fix shared work checksum mismatch/rebuild issues
Similar to the last shared work task signature bug, we've found another one. Looking at the improved output of diffsigs in this case: runtaskdeps changed from [ 'autoconf_2.69.bb.do_populate_sysroot:virtual:native', 'gnu-config_20120814.bb.do_populate_sysroot:virtual:native', 'libgcc-initial_4.9.bb.do_patch:virtual:nativesdk' ] to [ 'autoconf_2.69.bb.do_populate_sysroot:virtual:native', 'gcc-crosssdk-initial_4.9.bb.do_patch', 'gnu-config_20120814.bb.do_populate_sysroot:virtual:native' ] so we can get a different task hash since libgcc sorts before gnu-config and gcc sorts after it. We could do with a way of fixing this, the best I can come up with is to include a single parent directory. Since recipes are never at the top of any metadata trees I've seen, this should suffice for now. I'm planning to burn the concept of shared work within bitbake and do something at the metadata level in the 1.8 timeframe as its just too fragile as things stand and hard to fix well. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/siggen.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/lib/bb/siggen.py b/lib/bb/siggen.py
index 86d9ca059..28f93bae7 100644
--- a/lib/bb/siggen.py
+++ b/lib/bb/siggen.py
@@ -295,10 +295,9 @@ def dump_this_task(outfile, d):
bb.parse.siggen.dump_sigtask(fn, task, outfile, "customfile")
def clean_basepath(a):
+ b = a.rsplit("/", 2)[1] + a.rsplit("/", 2)[2]
if a.startswith("virtual:"):
- b = a.rsplit("/", 1)[1] + ":" + a.rsplit(":", 1)[0]
- else:
- b = a.rsplit("/", 1)[1]
+ b = b + ":" + a.rsplit(":", 1)[0]
return b
def clean_basepaths(a):