summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-31 23:43:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-01 08:54:33 +0100
commitc9534f8e59d44b885334607ed90a3be2e492ec69 (patch)
tree0662e3b4e68f749e8139bdde9dfa373a0c012d16
parent42144a54979658f93fbbb43f7e271c1fff4d88ff (diff)
downloadbitbake-c9534f8e59d44b885334607ed90a3be2e492ec69.tar.gz
build: Fix profile file names
Using the basename of the .bb file is not unique, for example xxx-native and xxx can overwrite each other. If this happens whilst running, you can get odd backtraces as one file is parsed as another tries to write out new data. Avoid issues by using PN for the output filename instead. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/build.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/build.py b/lib/bb/build.py
index 91c3a42db..a53aba9c1 100644
--- a/lib/bb/build.py
+++ b/lib/bb/build.py
@@ -467,7 +467,7 @@ def exec_task(fn, task, d, profile = False):
quieterr = True
if profile:
- profname = "profile-%s.log" % (os.path.basename(fn) + "-" + task)
+ profname = "profile-%s.log" % (d.getVar("PN", True) + "-" + task)
try:
import cProfile as profile
except: