aboutsummaryrefslogtreecommitdiffstats
path: root/lib/toaster/tests/toaster-tests-requirements.txt
diff options
context:
space:
mode:
authorAlassane Yattara <alassane.yattara@savoirfairelinux.com>2023-10-25 19:40:20 +0100
committerAlassane Yattara <alassane.yattara@savoirfairelinux.com>2023-11-09 18:33:50 +0100
commit227478b5aaee0f16945035c126ac18174340bba3 (patch)
tree7e4f30a2402dd29a48144be2d85d6eb326deab59 /lib/toaster/tests/toaster-tests-requirements.txt
parent595176d6be95a9c4718d3a40499d1eb576b535f5 (diff)
downloadbitbake-contrib-227478b5aaee0f16945035c126ac18174340bba3.tar.gz
Toaster: Update toaster-requirements.txt and Added pytest.ini
*** Update toaster-requirements.txt *** Add pytest and some plugin's - Pytest-html is a plugin for pytest that generates a HTML report for test results. - Pytest-django allows us to test Django project/applications with the pytest testing tool. - Pytest-env is a pytest plugin that enables us to set environment variables in a pytest.ini or pyproject.toml file - Pytest-metadata is a plugin for pytest that provides access to test session metadata, required by pytest-html plugin to provides metadata information in the HTML report like below: Python 3.10.12 Platform Linux-6.2.0-35-generic-x86_64-with-glibc2.35 Packages: - pytest: 7.4.2 - pluggy: 1.3.0 Plugins : - django: 4.5.2 - metadata: 3.0.0 - order: 1.1.0 - html: 4.0.2 - env: 1.1.0 *** Added pytest.ini file *** The main reason for using pytest is to be able to generate a positive test report using the pytest-html plugin. Integrating Pytest with Tox is a straightforward process, this can be done using tox.ini instead of pytest.ini used to configure pytest, that is another reason for using pytest. Tox is a tool that automates testing across different virtual environments, it can help ensure application will be tested against multiple Python versions and environments. https://github.com/pytest-dev/pytest/blob/main/tox.ini Generated reports create a historical record of test results over time. This can help track the progress of the application's stability and quality Documentation and Transparency: Test reports provide us a clear and detailed documentation of the test results. They show what tests were executed, which ones passed, and which ones failed. This transparency is critical for understanding the current state of the application and its test coverage. Communication: Test reports are an effective means of communication among community to understand the testing progress and results. Debugging, Troubleshooting Historical Tracking and Regression Testing: In case of test failures, a detailed test report can be invaluable for debugging. It provides information about the specific test case that failed, the input data used, and any error messages. Signed-off-by: Alassane Yattara <alassane.yattara@savoirfairelinux.com>
Diffstat (limited to 'lib/toaster/tests/toaster-tests-requirements.txt')
-rw-r--r--lib/toaster/tests/toaster-tests-requirements.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/toaster/tests/toaster-tests-requirements.txt b/lib/toaster/tests/toaster-tests-requirements.txt
index f30ac0706..7109c625d 100644
--- a/lib/toaster/tests/toaster-tests-requirements.txt
+++ b/lib/toaster/tests/toaster-tests-requirements.txt
@@ -1 +1,6 @@
selenium>=4.13.0
+pytest==7.4.2
+pytest-django==4.5.2
+pytest-env==1.1.0
+pytest-html==4.0.2
+pytest-metadata==3.0.0