aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bblayers/query.py
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-10-30 15:46:28 +1300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2017-11-08 15:15:11 +1300
commit6791df64f4c46baca11aabaae197d036b21220fc (patch)
tree2081d516c49d325849f6438aa59283971ec9b71c /lib/bblayers/query.py
parent622ac7b14aa743912bda5f6ab1f30aa904ef51d0 (diff)
downloadbitbake-contrib-6791df64f4c46baca11aabaae197d036b21220fc.tar.gz
bitbake-layers: show-recipes: fix help to mention -i supports multiple classespaule/bblayers-fix2
The -i option supports more than one class, but the help didn't mention that. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'lib/bblayers/query.py')
-rw-r--r--lib/bblayers/query.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bblayers/query.py b/lib/bblayers/query.py
index efd22cb45..9294dfa88 100644
--- a/lib/bblayers/query.py
+++ b/lib/bblayers/query.py
@@ -490,7 +490,7 @@ NOTE: .bbappend files can impact the dependencies.
parser_show_recipes = self.add_command(sp, 'show-recipes', self.do_show_recipes)
parser_show_recipes.add_argument('-f', '--filenames', help='instead of the default formatting, list filenames of higher priority recipes with the ones they overlay indented underneath', action='store_true')
parser_show_recipes.add_argument('-m', '--multiple', help='only list where multiple recipes (in the same layer or different layers) exist for the same recipe name', action='store_true')
- parser_show_recipes.add_argument('-i', '--inherits', help='only list recipes that inherit the named class', metavar='CLASS', default='')
+ parser_show_recipes.add_argument('-i', '--inherits', help='only list recipes that inherit the named class(es) - separate multiple classes using , (without spaces)', metavar='CLASS', default='')
parser_show_recipes.add_argument('pnspec', nargs='*', help='optional recipe name specification (wildcards allowed, enclose in quotes to avoid shell expansion)')
parser_show_appends = self.add_command(sp, 'show-appends', self.do_show_appends)